re = /(?=.*[+-]\d+\.\d+).*([+-]\d+\.\d+).*|(.*)/m
str = 'Stephane Robert (+1.5 Sets)
Stephane Robert (-1.5 Sets)
Philipp Kohlschreiber
Philipp Kohlschreiber (-1.5 Sets)
Philipp Kohlschreiber (+1.5 Sets)
Player Names (n)
Another Player-Player'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result