const regex = /([^0-9]|^)(7534567|7134576)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^0-9]|^)(7534567|7134576)$', 'gm')
const str = `abc7534567
def7134576
def17134576`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}