$re = '/([^0-9]|^)(7534567|7134576)$/m';
$str = 'abc7534567
def7134576
def17134576';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);