re = /\s(\d\S*)\s/m
str = 'scsm 7.2.4.8023 LogRhythm System Monitor Agent for AIX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end