# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b(pre1|pre2)?WORD(suf1|suf2)?\b)"
test_str = ("1. Xxx xxx WORDsuf1 xxx xxx xxx.\n"
"2. Xxx xxx WORDsuf2 xxx xxx xxx.\n"
"3. Xxx xxx pre1WORDsuf1 xxx xxx xxx.\n"
"4. Xxx xxx WORD xxx xxx xxx.\n"
"5. Xxx xxx pre1WORD xxx xxx xxx.\n"
"6. Xxx xxx pre2WORDxxx xxx xxx xxx.\n"
"7. Xxx xxx xxxWORDxxx xxx xxx xxx.\n"
"8. Xxx xxx pre1WORDxxxsuf1 xxx xxx xxx.\n"
"9. Xxx xxx pre1xxxWORDsuf1 xxx xxx xxx.\n"
"10. Xxx xxx xxxWORDxxx xxx xxx xxx.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.