$re = '/"<li><span>.*?<\/span><\/li>"/';
$str = '"<li><span>3-1/2-inch cutting edge and wedge-shaped spike</span></li>"
"<li><span>19-inch overall length; 24-ounce weight</span></li>"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);