re = /"<li><span>.*?<\/span><\/li>"/
str = '"<li><span>3-1/2-inch cutting edge and wedge-shaped spike</span></li>"
"<li><span>19-inch overall length; 24-ounce weight</span></li>"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end