$re = '/^(([a-zA-Z]{2}|[0-9]{2})[0-9]{6})?$/m';
$str = 'ab123456
12345678
aa441236
aw222222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);