import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^0-9\\n])\"((\\b\\d+(?:\\.\\d+)?\"|[^\"\\n])+)\"";
final String string = "\"test\" Senkatel \"woo69\" 2\"-5\" Maximus 10.1\" \"White\"\n"
+ "Product: \"Senkatel Maximus 10.1\"\"\n"
+ "Dims: 4\" x 6\"\n"
+ "\"Film: 300\"\n"
+ "\"Senkatel 10.1\" Maximus\"\n"
+ "Senkatel Maximus 10.1\" \"White\"\n"
+ "Senkatel Maximus 10.1\" \"Moonlight blue\"\n"
+ "\"Senkatel Maximus 10.1\"\"\n"
+ "Dims: A\" x B\"\n"
+ "Dims: \"A\"";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}