$re = '/(^|[^0-9\n])"((\b\d+(?:\.\d+)?"|[^"\n])+)"/ms';
$str = '"test" Senkatel "woo69" 2"-5" Maximus 10.1" "White"
Product: "Senkatel Maximus 10.1""
Dims: 4" x 6"
"Film: 300"
"Senkatel 10.1" Maximus"
Senkatel Maximus 10.1" "White"
Senkatel Maximus 10.1" "Moonlight blue"
"Senkatel Maximus 10.1""
Dims: A" x B"
Dims: "A"';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;