#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?<=\d\/|\.be\/|v[=\/])([\w\-]{11,})|^([\w\-]{11})$"
Local $sString = "http://www.youtube.com/watch?v=vpiMAaPTze8" & @CRLF & _
"http://youtu.be/l_la5XiQJdk" & @CRLF & _
"l_la5XiQJdk" & @CRLF & _
"thisdoesnotmatch"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")