re = /(?<=\d\/|\.be\/|v[=\/])([\w\-]{11,})|^([\w\-]{11})$/im
str = 'http://www.youtube.com/watch?v=vpiMAaPTze8
http://youtu.be/l_la5XiQJdk
l_la5XiQJdk
thisdoesnotmatch'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end