import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w.*solarwinds.orion\\\\(solarwinds.*|swjobengine.*|netflowservice.*|counterfetcher.*)\\.exe$";
final String string = "// Explanation\n"
+ "// Matches all files part of the \"orion\" folder that start with solarwinds,swjobengine,netflowservice,counterfetcher and ends with \".exe\"\n\n"
+ "// Some Solarwinds exe starting with \"solarwinds.\"\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.syslogservice.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.businesslayerhostx64.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.syslogservice.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.collector.service.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.pollingservice.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.businesslayerhost.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.trapservice.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.recommendations.service.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.informationservice.servicev3.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.highavailability.service.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.servicehost.process.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.topology.calculator.exe\n\n"
+ "// Example with another drive\n"
+ "C:\\program files\\solarwinds\\orion\\solarwinds.topology.calculator.exe\n\n"
+ "// Some Solarwinds exe NOT starting with \"solarwinds.\"\n"
+ "e:\\program files\\solarwinds\\orion\\netflowservice.exe\n"
+ "e:\\program files\\solarwinds\\orion\\swjobengineworker2.exe\n"
+ "e:\\program files\\solarwinds\\orion\\swjobenginesvc2.exe\n"
+ "e:\\program files\\solarwinds\\orion\\swjobengineworker2x64.exe\n"
+ "e:\\program files\\solarwinds\\orion\\counterfetcher.exe\n\n"
+ "// Non Orion folders\n"
+ "c:\\program files\\common files\\solarwinds\\administrationservice\\solarwinds.administration.exe\n\n\n"
+ "// TESTS\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.test.exe\n"
+ "e:\\program files\\solarwinds\\orion\\solarwinds.test.test2.exe\n\n"
+ "Without orion folder\n"
+ "e:\\program files\\solarwinds\\NotOrion\\solarwinds.servicehost.process.exe\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}