import re
regex = re.compile(r"^(x ).*$", flags=re.MULTILINE)
test_str = ("x 2017-12-12 @geek add file location preference option +todotxtapp\n"
"(A) @geek completed task syntax highlighter rule needs tweak - it includes any character follows with whitespace - starting in the middle of the line +todotxtapp\n"
" (B) @geek design new app icon +todotxtapp\n"
"(C) @geek add priority shortcut cmd+up/down or similar +todotxtapp\n"
" asdasdasdasdasa dsljhdsfkljg dhsklf sdaf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")