re = /^(x ).*$/m
str = 'x 2017-12-12 @geek add file location preference option +todotxtapp
(A) @geek completed task syntax highlighter rule needs tweak - it includes any character follows with whitespace - starting in the middle of the line +todotxtapp
(B) @geek design new app icon +todotxtapp
(C) @geek add priority shortcut cmd+up/down or similar +todotxtapp
asdasdasdasdasa dsljhdsfkljg dhsklf sdaf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end