import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+) packets transmitted, (\\d+) .*received, ([\\d.]+)% .*loss[^]*= ([\\d.]+)\\/([\\d.]+)\\/([\\d.]+)\\/?([\\d.]+)";
final String string = "3 packets transmitted, 3 packets received, 0% packet loss\n"
+ "round-trip min/avg/max = 14.593/15.220/15.628 ms";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}