const regex = /(\d+) packets transmitted, (\d+) .*received, ([\d.]+)% .*loss[^]*= ([\d.]+)\/([\d.]+)\/([\d.]+)\/?([\d.]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+) packets transmitted, (\\d+) .*received, ([\\d.]+)% .*loss[^]*= ([\\d.]+)\\\/([\\d.]+)\\\/([\\d.]+)\\\/?([\\d.]+)', '')
const str = `3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 14.593/15.220/15.628 ms`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}