#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\(?<log_name>\w+\.\w+)$"
Local $sString = "blah\blah\blah\logs\error.log" & @CRLF & _
"" & @CRLF & _
"blah\blah\blah\logs\audit.log" & @CRLF & _
"" & @CRLF & _
"blah\blah\blah\logs\utility.log" & @CRLF & _
"" & @CRLF & _
"blah\blah\blah\logs\service.log" & @CRLF & _
"" & @CRLF & _
"blah\blah\blah\logs\servlet.log"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")