#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https?)://((www\.)?example\.com)/([a-z0-9]{12})/([\w-]+\.?(?:[\w-]+|\.(?!html?$))*)"
Local $sString = "https://example.com/4scdhh0gifzd/my-file.txt.html" & @CRLF & _
"https://example.com/4scdhh0gifzd/my-file.txt.htm" & @CRLF & _
"https://example.com/4scdhh0gifzd/my-file.txt" & @CRLF & _
"" & @CRLF & _
"https://example.com/4scdhh0gifzd/my-file.txt.html" & @CRLF & _
"Нужно получить my-file.txt вместо my-file.txt.html" & @CRLF & _
"" & @CRLF & _
"https://example.com/4scdhh0gifzd/my-file.txt.html.html" & @CRLF & _
"Нужно получить my-file.txt.html вместо my-file.txt.html.html" & @CRLF & _
"" & @CRLF & _
"https://example.com/4scdhh0gifzd/my-file.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")