const regex = /^(?=(?:\/[a-z0-9s_@\/.-]{1,255})+)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:\\\/[a-z0-9s_@\\\/.-]{1,255})+)$', 'i')
const str = `/home/rs/testwithlongdirectory/BPLrmwQ/dsadsadddddddddddddddddddddddddddddddddddddddddddddddddddddddddzxvcxv34d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}