$re = '/^(?=(?:\/[a-z0-9s_@\/.-]{1,255})+)$/i';
$str = '/home/rs/testwithlongdirectory/BPLrmwQ/dsadsadddddddddddddddddddddddddddddddddddddddddddddddddddddddddzxvcxv34d';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);