const regex = /^(?=(?:\/[a-z0-9s_@\-/.]{1,255})+).{1,4095}$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:\\\/[a-z0-9s_@\\-\/.]{1,255})+).{1,4095}$', 'i')
const str = `/whatever/thisisnotapornstash/StillNot255CharactersButTheNextFolderIs/BPLrmwQRjmtwIGEMDcgGk1BCRY6ZkKzsHoWqJNzGxCzlGTSZkfOei0QD2S3bGfqSMJMPxuvgHhUJotNgh3hGDYD01n56JiZy32JygaHHDLQbGWtkbFJy5BrMP5s6eL6V8Kcft71CxHZUMEEJ2LbYExYtPxaWuQ9USUCxbt7wTIjALoLN6aHW0GovD5euXWsYuOsqvyGuzJqjaohM9FFNmMz7ul0R4HxzTWWQqCZ8hp6O2yipRTs5k4RmGCTLfdsadsanY/ `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}