re = /^(?=(?:\/[a-z0-9s_@\-\/.]{1,255})+).{1,4095}$/i
str = '/whatever/thisisnotapornstash/StillNot255CharactersButTheNextFolderIs/BPLrmwQRjmtwIGEMDcgGk1BCRY6ZkKzsHoWqJNzGxCzlGTSZkfOei0QD2S3bGfqSMJMPxuvgHhUJotNgh3hGDYD01n56JiZy32JygaHHDLQbGWtkbFJy5BrMP5s6eL6V8Kcft71CxHZUMEEJ2LbYExYtPxaWuQ9USUCxbt7wTIjALoLN6aHW0GovD5euXWsYuOsqvyGuzJqjaohM9FFNmMz7ul0R4HxzTWWQqCZ8hp6O2yipRTs5k4RmGCTLfdsadsanY/ '
# Print the match result
str.match(re) do |match|
puts match.to_s
end