package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<token>%[-\+ #0]?(?:\d+(?:\.\d+)?)?[hljztL]?[hl]?[diuoxXfFeEgGaAspn]u?)`)
var str = `"connected to %s:%d", ip, port`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}