re = /(?P<token>%[-\+ #0]?(?:\d+(?:\.\d+)?)?[hljztL]?[hl]?[diuoxXfFeEgGaAspn]u?)/
str = '"connected to %s:%d", ip, port'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end