package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)version=OpenSSH_\D*(\d\.\d)`)
var str = `version=OpenSSH_for_Windows_7.7p1, LibreSSL 2.6.4
version=OpenSSH_7.1p1 Microsoft_Win32_port_with_VS Dec 22 2015, OpenSSL 1.0.2d 9 Jul 2015`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}