import re
regex = re.compile(r"version=OpenSSH_\D*(\d\.\d)", flags=re.MULTILINE)
test_str = ("version=OpenSSH_for_Windows_7.7p1, LibreSSL 2.6.4\n"
"version=OpenSSH_7.1p1 Microsoft_Win32_port_with_VS Dec 22 2015, OpenSSL 1.0.2d 9 Jul 2015")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")