$re = '/^[a-zA-Z]{3,4}(\d{6})((\D|\d){3})?$/';
$str = 'CUPU800825569';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);