package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.*)\/(.*)\/(.*)$`)
var str = `/p1/abc/p2/dir/data.x`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}