$re = '/^(.*)\/(.*)\/(.*)$/';
$str = '/p1/abc/p2/dir/data.x';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);