$re = '/^(?=.*[a-z])(?=.*\d)[a-z\d]+$/i';
$str = 'ieoEon43
43ifsiojfdfs
6i
ijf943kNFSfsf
foo bar';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);