re = /^(?=.*[a-z])(?=.*\d)[a-z\d]+$/i
str = 'ieoEon43
43ifsiojfdfs
6i
ijf943kNFSfsf
foo bar'
# Print the match result
str.match(re) do |match|
puts match.to_s
end