import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^]]+)]\\s*Title=Eastern North America";
final String string = "[Area.104]\n"
+ "Title=Central North America\n"
+ "Local=Scenery\\NAMC\n"
+ "Layer=104\n"
+ "Active=TRUE\n"
+ "Required=FALSE\n\n"
+ "[Area.105]\n"
+ "Title=Eastern North America\n"
+ "Local=Scenery\\NAME\n"
+ "Layer=105\n"
+ "Active=TRUE\n"
+ "Required=FALSE\n\n"
+ "[Area.106]\n"
+ "Title=Western North America\n"
+ "Local=Scenery\\NAMW\n"
+ "Layer=106\n"
+ "Active=TRUE\n"
+ "Required=FALSE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}