re = /\[([^]]+)]\s*Title=Eastern North America/m
str = '[Area.104]
Title=Central North America
Local=Scenery\\NAMC
Layer=104
Active=TRUE
Required=FALSE
[Area.105]
Title=Eastern North America
Local=Scenery\\NAME
Layer=105
Active=TRUE
Required=FALSE
[Area.106]
Title=Western North America
Local=Scenery\\NAMW
Layer=106
Active=TRUE
Required=FALSE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end