using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]+[\s][a-zA-Z]+[\s][a-zA-Z]+[\s][a-zA-Z]+([\s])?[a-zA-Z]+(\')?([a-zA-Z]+([\s])?)$";
string input = @"43 rue de l'ecole";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}