re = /^[0-9]+[\s][a-zA-Z]+[\s][a-zA-Z]+[\s][a-zA-Z]+([\s])?[a-zA-Z]+(\')?([a-zA-Z]+([\s])?)$/mi
str = '43 rue de l\'ecole'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end