# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<span class='indent'>.*?(<br>).*?<\\/span>//g;t' <<< "<span class='together'>line one,<br><span class='indent'>line two.</span><br>Line three,<br><span class='indent'>line four,<br>line five,<br>line six,<br>line seven;<br>line eight.<br>Line nine;<br>line ten,<br>line eleven,<br>line twelve.</span><br>Line thriteen,<br><span class='indent'>line fourteen,<br>line fifteen,<br>line sixteen,<br>line seventeen,<br>line eighteen.</span></span>"