$re = '/^(?! )[A-Za-z0-9 ]*(?<! )$/m';
$str = 'Abc132 3sdfas
asd dsadas
$das dsfds
Te st';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);