#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(degree(s)? of)(\n?|.+?)(\w.+|\w?.+\n.+)"
Local $sString = "MIT Sample:" & @CRLF & _
"AN EXPERIMENTAL INVESTIGATION OF" & @CRLF & _
"OIL SPREADING OVER WATER" & @CRLF & _
"by" & @CRLF & _
"Walter Suchon" & @CRLF & _
"Submitted in Partial Fulfillment" & @CRLF & _
"of the Requirements for the" & @CRLF & _
"degrees of" & @CRLF & _
"bachelor of science" & @CRLF & _
"and" & @CRLF & _
"Master of Science" & @CRLF & _
"at the" & @CRLF & _
"MASSACHUSETTS INSTITUTE OF TECHNOLOGY" & @CRLF & _
"April, 1970" & @CRLF & _
"Signature of Author" & @CRLF & _
"Department of Mechanical Engineering" & @CRLF & _
"Certified by......." & @CRLF & _
"Thesis Supervisor" & @CRLF & _
"Accepted by" & @CRLF & _
"Chairman, Departmental Committee on Graduate Students" & @CRLF & _
"Archives" & @CRLF & _
"MASS INST. TECH." & @CRLF & _
"SEP 10 1970" & @CRLF & _
"LIBRARIES" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"Virginia Tech Sample:" & @CRLF & _
"FUNDAMENTAL ADHESIVE STUDIES OF BLOCK COPOLYMERS" & @CRLF & _
"by" & @CRLF & _
"Margaret Mary Sheridan" & @CRLF & _
"Dissertation submitted to the Faculty of the" & @CRLF & _
"Virginia Polytechnic Institute and State University" & @CRLF & _
"in partial fulfillment of the requirements for the degree of" & @CRLF & _
"Doctor of Philosophy" & @CRLF & _
"in" & @CRLF & _
"Chemistry" & @CRLF & _
"APPROVED:" & @CRLF & _
"T.C. Ward, Chairman" & @CRLF & _
"D.W. Dwight M.A. Oglioruso" & @CRLF & _
"J.E. McGrath J.P. Wightman" & @CRLF & _
"October, 1985" & @CRLF & _
"Blacksburg, Virginia"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")