using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^9(0\d{10})$";
string input = @"901234567890
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}