const regex = /[^()]+(?=\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^()]+(?=\\))', 'gm')
const str = `textA(textB)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);