$re = '/[^()]+(?=\))/m';
$str = 'textA(textB)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;