using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([(\d\.)]+) - - \[(.*?)\] \""(.*?)\"" (\d+) - \""(.*?)\"" \""(.*?)\""";
string input = @"64.233.160.5 - - [06/Jan/2019:14:04:19 +0200] ""GET / HTTP/1.1"" 200 - "" ""Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}