import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([(\\d\\.)]+) - - \\[(.*?)\\] \\\"(.*?)\\\" (\\d+) - \\\"(.*?)\\\" \\\"(.*?)\\\"";
final String string = "64.233.160.5 - - [06/Jan/2019:14:04:19 +0200] \"GET / HTTP/1.1\" 200 - \"\" \"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}