re = /(\d+)/
str = '<span class="labelbitdetail green"><i class="icon-thumbs-up norightmargin"></i>527</span>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end