import re
regex = re.compile(r"# Time.*?root.*?(?!# Time)", flags=re.DOTALL)
test_str = ("# Time: 230706 17:12:48\n"
"# User@Host: sample[sample] @ localhost []\n"
"# Thread_id: 626784 Schema: sample QC_hit: No\n"
"# Query_time: 2.976557 Lock_time: 0.000178 Rows_sent: 0 Rows_examined: 3344231\n"
"# Rows_affected: 0 Bytes_sent: 195\n"
"SET timestamp=1688677968;\n"
"SELECT * from a;\n\n"
"# Time: 230706 17:15:51\n"
"# User@Host: root[root] @ localhost []\n"
"# Thread_id: 627770 Schema: sample QC_hit: No\n"
"# Query_time: 2.581676 Lock_time: 0.000270 Rows_sent: 0 Rows_examined: 2432228\n"
"# Rows_affected: 0 Bytes_sent: 195\n"
"SET timestamp=1688678151;\n"
"select * from cs;\n\n"
"# Time: 230706 17:13:37\n"
"# User@Host: sample[sample] @ localhost []\n"
"# Thread_id: 627027 Schema: oiemorug_wp598 QC_hit: No\n"
"# Query_time: 3.901325 Lock_time: 0.000145 Rows_sent: 0 Rows_examined: 3851050\n"
"# Rows_affected: 0 Bytes_sent: 195\n"
"SET timestamp=1688678017;\n"
"SELECT * from b\n\n"
"# Time: 230706 17:15:51\n"
"# User@Host: root[root] @ localhost []\n"
"# Thread_id: 627770 Schema: sample QC_hit: No\n"
"# Query_time: 2.581676 Lock_time: 0.000270 Rows_sent: 0 Rows_examined: 2432228\n"
"# Rows_affected: 0 Bytes_sent: 195\n"
"SET timestamp=1688678151;\n"
"select * from cs")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")