re = /<claim-text>([^<\r\n]*)/m
str = '<claim-text>aaaaaaa
<claim-text>bbbbbbb</claim-text>
<claim-text>ccccccc</claim-text>
</claim-text>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end