$re = '/class(?=="field")/';
$str = ' <div class="something else field">Foo</div>
<span class="field">Bar</span>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);