re = /class(?=="field")/
str = ' <div class="something else field">Foo</div>
<span class="field">Bar</span>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end