$re = '/(?<=\bstyle="[^"]*)#[A-F0-9]{6}\b(?=[^"]*")/m';
$str = '<span style="color: #FF0000;background-color: #FFFF99;font-family: Calibri;font-size: 11pt;font-weight: bold;font-style: normal">This shouldn\'t be in result #FFFF99</span>
<span style="color: #FF0000;background-color: #FFFF99;font-family: Calibri;font-size: 11pt;font-weight: bold;font-style: normal">This shouldn\'t be in result #FFFF99</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);